Platform outage
Incident Report for Siteimprove
Postmortem

This outage was caused by a planned maintenance event. Unfortunately our normal procedure for communicating such maintenance was not followed correctly (the maintenance was communicated internally but not externally), and therefore customers were not prepared.

The maintenance was carried out outside of normal business hours for most of our customers, but unfortunately some of customers were affected, and we want to apologize for the inconvenience we caused.

Going forward we are increasing the number of days in advance we announce planned maintenance (urgent maintenance may still be necessary from time to time), and we’re looking into improving how we announce maintenance to make sure our users see it.

Posted 2 months ago. Sep 26, 2018 - 12:42 UTC

Resolved
Today the platform was unavailable for some customers for a duration of about an hour. This was caused by planned maintenance, but unfortunately we failed to communicate the planned maintenance on this statuspage, which is our normal procedure. We apologize for the mistake and any inconvenience it may have caused.
Posted 3 months ago. Sep 25, 2018 - 05:00 UTC