Single Page Checks and Pre-Publish Checks Delayed
Incident Report for Siteimprove
Resolved
We have implemented multiple changes that have improved the duration of checknows and pre-publish checks, and we're now back to normal operations. Thank you for your patience.
Posted Nov 30, 2020 - 08:33 UTC
Monitoring
We have implemented a fix to speed up the execution of single page checks (checknows) and pre-publish checks, and will be monitoring the impact for a while. So far we have registered a multi-second reduction in processing time, so we are optimistic, but we still want to see the effect on higher activity levels.
Posted Nov 27, 2020 - 14:18 UTC
Update
Updated incident to reflect that this is also affecting pre-publish checks.
Posted Nov 26, 2020 - 13:13 UTC
Identified
We have identified a bottleneck in the system that was surfaced due to recently added load. We're working on eliminating this bottleneck, and hope to be back to normal performance levels soon.
Posted Nov 26, 2020 - 08:30 UTC
Investigating
Single Page Checks are currently processed slower than usual. We are investigating.
Posted Nov 25, 2020 - 13:03 UTC
This incident affected: Platform.