Platform - Outage

Incident Report for Siteimprove

Resolved

Nice! The issue affecting the Siteimprove platform from loading is all sorted.

We’re sorry for holding you up! If you have any additional questions or feedback, please submit a new support ticket through our Help Center located at the bottom right-hand-side of the Siteimprove platform.
Posted Mar 31, 2025 - 06:50 UTC

Update

We are continuing to investigate this issue.
Posted Mar 31, 2025 - 06:03 UTC

Investigating

Uh oh! We seem to be having a problem.

Our team is making every effort to get things up and running again.

You may be unable to access and log into the Siteimprove platform (my2.siteimprove.com).

We’ll have an update at the top of the hour. Stay tuned!
Posted Mar 31, 2025 - 05:53 UTC
This incident affected: Platform.