Intermittent Platform Outages
Incident Report for Siteimprove
Resolved
We have implemented several fixes, and have verified that the stability of the platform has been greatly improved.
Posted about 1 month ago. Jun 13, 2018 - 10:54 UTC
Investigating
The Siteimprove platform has been experiencing intermittent outages recently. We are aware of the issues and are investigating their cause.
Posted 2 months ago. May 07, 2018 - 20:39 UTC
This incident affected: Platform.