Page Report for Quality Assurance unavailable
Incident Report for Siteimprove
Resolved
Page Report is now again available to all customers. We apologize for the inconvenience.
Posted about 2 months ago. Jul 05, 2017 - 14:22 UTC
Identified
We currently see failures to load the Quality Assurance report for a number of our customers.
The cause of the issue has been pinpointed and we are working to put a solution live asap.
Posted about 2 months ago. Jul 05, 2017 - 13:06 UTC