Platform Slowness Issues
Incident Report for Siteimprove
Resolved
We are no longer seeing issues with the platform.
Posted Feb 23, 2021 - 20:29 UTC
Monitoring
We believe we have resolved the issues with slow performance at this time. Some users also reported problems with a NOTRANSLATION message appearing in place of some platform buttons/links. We are no longer seeing that issue appear as well. We will continue to monitor the situation for approximately 30 minutes to ensure there are no further concerns.
Posted Feb 23, 2021 - 19:59 UTC
Update
We continue to work on this issue as a high priority. Updates will be provided when new information is available. Users may continue to experience intermittent or brief periods of slow platform performance until the issue has been resolved.
Posted Feb 23, 2021 - 18:09 UTC
Update
We continue to work on this issue as a high priority. Updates will be provided when new information is available. Users may continue to experience intermittent or brief periods of slow platform performance until the issue has been resolved.
Posted Feb 23, 2021 - 16:11 UTC
Investigating
We are seeing issues with users experiencing slow responses or intermittent errors when using the Siteimprove platform currently. We are working on the issue as a high priority and will provide updates as new information becomes available.
Posted Feb 23, 2021 - 14:40 UTC
This incident affected: Platform and API / Integrations.