Service Degradation - US/Canada
Incident Report for Siteimprove
Resolved
This incident has been resolved.
Posted Mar 27, 2020 - 20:21 UTC
Monitoring
Performance has improved and we are monitoring it.
Posted Mar 27, 2020 - 19:30 UTC
Identified
The issue appears to be affecting only US/Canadian customers and is related to ISP networking. We continue to work on resolving the issue, but do not currently have an estimated time to resolve.
Posted Mar 27, 2020 - 16:41 UTC
Investigating
We are currently investigating this issue.
Posted Mar 27, 2020 - 15:16 UTC
This incident affected: Platform and API / Integrations.