Platform Outage
Incident Report for Siteimprove
Resolved
The platform has returned to normal operations.
Posted about 1 month ago. Apr 20, 2018 - 19:26 UTC
Monitoring
Issue has been identified and platform is back online. We're continuing to monitor the situation closely.
Posted about 1 month ago. Apr 20, 2018 - 16:42 UTC
Investigating
We are currently experiencing an issue with our Platform and are investigating the cause
Posted about 1 month ago. Apr 20, 2018 - 16:19 UTC