Delayed logon
Incident Report for Siteimprove
Resolved
The cause for the performance degradation has been found and eliminated. We apologize for the inconvenience.
Posted about 2 months ago. May 03, 2017 - 10:21 UTC
Identified
Currently you may experience longer initial load times than normal when logging in to our platform.
Posted about 2 months ago. May 03, 2017 - 09:46 UTC