Delay in monthly and quarterly PDF Report delivery
Incident Report for Siteimprove
Resolved
We are now up to speed on report generation and delivery. We apologize for any inconvenience this delay may have caused.
Posted 4 months ago. Jul 03, 2017 - 12:51 UTC
Investigating
We are currently experiencing a backlog of primarily Analytics Reports that are waiting to be sent. We are seeing reports currently being delayed by up to two days.
Posted 4 months ago. Jul 03, 2017 - 07:53 UTC